[Laszlo-user] Proposal to make `isinited` obsolete, add `inited`, which actually corresponds to `init` having been executed

P T Withington ptw at pobox.com
Thu Dec 11 08:43:26 PST 2008


On 2008-12-11, at 11:38EST, P T Withington wrote:

> Here is a proposal I would like to make:
>
> 1) Deprecate `isinited`:  It's inconsistent with our naming scheme.   
> It does not correspond to init being called.  (It is set before  
> references have been resolved and before init has been called!)
>
> 2) Add a new attribute, `inited`, that is set just after `oninit`  
> (and thus reflects that init has been called).  This is consistent  
> with the state API apply/onapply/applied.
>
> Your comments requested.

Filed as:

http://jira.openlaszlo.org/jira/browse/LPP-7453

If you would like to record your comments there, it would be helpful.



More information about the Laszlo-user mailing list