[Laszlo-user] Custom Context Menus?

Henry Minsky henry.minsky at gmail.com
Fri Mar 17 12:32:50 EST 2006


I guess it was post 3.1 then.. sorry about that.

We saw what seemed to be a strange regression in the behavior of the context
menus between swf7 and swf8 where context menus could only be attached to
movieclips that were direct children of the root movieclip. I need to
investigate this.

There was also a name conflict when the context menu is attach to the
canvas, it occupies the name 'menu' which overwrites the 'menu' GUI
component. We solved that by making, as Scott mentioned, a movieclip that
covers the entire canvas, at a low depth, which holds the rightclick menu.



On 3/17/06, James Howe <openlaszlo at wingspread.imap-mail.com> wrote:
>
> I notice that your documentation refers to LzContextMenu, but when I try
> to use that the debugger tells me that LzContextMenu is undefined.  Is
> LzContextMenu only available in the 3.2 release (which is still an RC
> release, correct?)
>
> Does the ContextMenu stuff work in 3.1.1?
>
> Thanks!
>
>
> On Fri, 17 Mar 2006 10:57:15 -0500, John Sundman
> <jsundman at laszlosystems.com> wrote:
>
> > I believe -- although I am not entirely certain; would have to check --
> > that I rewrote some of that documentation for the 3.2 release.
> >
> > You may want to to check the docs in the nightly build.
> >
> > http://www.openlaszlo.org/lps-latest/docs/guide/input-
> > devices.html#d0e16072
> >
> > Sorry for any confusion.  As Scott said, holler back if you don't get it
> > working.
> >
> > jrs
> >
> > On Mar 17, 2006, at 8:44 AM, James Howe wrote:
> >
> >> I've noticed that LaszloMail has right mouse click context menus
> >> available
> >> in their latest version.  Are they using some new, unreleased Laszlo
> >> feature, or have I missed something?  I've read articles in the forum
> >> that
> >> describe how to create a ContextMenu, but I haven't been able to get
> >> them
> >> to work.  I even tried the sample code used to remove the 'View
> >> Source...'
> >>  from the context menu and that didn't work either.  Am I just doing
> >> something wrong?  I'm running 3.1.1.
> >>
> >> Thanks!
> >>
> >> --James Howe
> >> _______________________________________________
> >> Laszlo-user mailing list
> >> Laszlo-user at openlaszlo.org
> >> http://www.openlaszlo.org/mailman/listinfo/laszlo-user
> >
>
>
>
> --
> James Howe
> _______________________________________________
> Laszlo-user mailing list
> Laszlo-user at openlaszlo.org
> http://www.openlaszlo.org/mailman/listinfo/laszlo-user
>



--
Henry Minsky
Software Architect
hminsky at laszlosystems.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.openlaszlo.org/pipermail/laszlo-user/attachments/20060317/f1b77e90/attachment.html


More information about the Laszlo-user mailing list