[Laszlo-dev] Changing lzt=html to lzt=wrapper?
jsundman at laszlosystems.com
Fri Jan 19 04:26:17 PST 2007
I don't mind changing the docs because this is an area that is very
confusing and hard to explain and in need of an overhaul anyway.
Some of this information is in the Deployer's Guide and some of it is
scattered throughout the Developer's Guide, and there is much stale
information (for example lzt=history) that I have bugs against
anyway. Since I'm going to have to change it, I would rather change
it to something logical.
That does not address Henry's point about the code, however.
On Jan 18, 2007, at 11:19 PM, Henry Minsky wrote:
> That sounds like a good idea. Unfortunately there are a lot of
> places in the
> code and docs (and wrappers and solo deployer) that are going to be
> by that change. Where's our new summer intern ? :-)
> On 1/18/07, P T Withington <ptw at openlaszlo.org> wrote:
>> I'd rather change lz(request)t(ype) to lzw(rapper). Better yet,
>> we've discussed a number of times trying to unify the lz? options,
>> perhaps by saying something like:
>> [I don't know for a fact that that is or is not a legitimate URI
>> query parameter syntax, or if : and , already have reserved meanings
>> in query parameters. Presumably we could come up with something
>> along those lines.]
>> Similarly, the litany of server requests that are lumped into the ?
>> lzt argument should be split out as something like:
>> The biggest benefit is that we would remove a lot of pollution from
>> the query arg space (especially the non-lz-prefixed args like
>> profile, proxy, etc.).
>> If `runtime:dhtml,wrapper:html` is still confusing, I suggest we
>> change dhtml to ajax.
>> On 2007-01-18, at 20:36 EST, David Temkin wrote:
>> > With the addition of lzr=dhtml, lzt=html has become pretty
>> > Any thoughts on deprecating lzt=html in favor of lzt=wrapper, or
>> > something along those lines?
> Henry Minsky
> Software Architect
> hminsky at laszlosystems.com
More information about the Laszlo-dev